Author Topic: Weird sprite glitch.  (Read 549 times)

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Weird sprite glitch.
« on: July 25, 2018, 11:30:35 pm »


Has anyone seen something like this before, and is there a fix?

Acacia Sgt

  • Radical Dreamer (+2000)
  • *
  • Posts: 2395
  • Forever loyal to the Acacia Dragoons
    • View Profile
Re: Weird sprite glitch.
« Reply #1 on: July 26, 2018, 12:17:33 am »
Huh, where exactly is that? I can tell it's one of Guardia Castle's towers, but not which one, or if the time period matters.

Hmm, can't say I've ever see that happen. Lower-left seems to be a King Guardia sprite (no idea if XXXIV or XXI), but not sure if that means anything.

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Re: Weird sprite glitch.
« Reply #2 on: July 26, 2018, 12:31:16 am »
It's the King's tower in 1000 AD. It probably has something to do with my attempt to make the king replace Crono, but I wanted to remove other possibilities.

Edit: Fixed the issue. I had to place my memory hackery after the Return in Startup/Idle.
« Last Edit: July 26, 2018, 01:04:38 am by Mauron »

IHBP

  • Architect of Kajar
  • Enlightened One (+200)
  • *
  • Posts: 233
    • View Profile
Re: Weird sprite glitch.
« Reply #3 on: August 01, 2018, 11:08:15 pm »
I've seen instances where the return is in the middle, I never understood the point of it.

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Re: Weird sprite glitch.
« Reply #4 on: August 01, 2018, 11:46:34 pm »
Return seems to delay certain code in the Startup/Idle section, but I don't fully understand it.

IHBP

  • Architect of Kajar
  • Enlightened One (+200)
  • *
  • Posts: 233
    • View Profile
Re: Weird sprite glitch.
« Reply #5 on: April 22, 2019, 02:53:51 pm »
Trying to find the topic where you replaced Crono with king Guardia, would like to put that to good use.

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Re: Weird sprite glitch.
« Reply #6 on: April 22, 2019, 06:10:48 pm »
Here's location events for the King's tower with playing as the king. The king is slow as fuck, running animations get wonky, and opening the menu causes issues.

Object 9 handles most of the magic. It loads the King sprites, mucks with some RAM values.

7E1100 + (object index * 2) Object type. 00 for PC, 80 for unused. Disable the PC you replace.

7E0197 PC1 Object number * 2. 7E0199 and 7E019B for PC2 and 3.

IHBP

  • Architect of Kajar
  • Enlightened One (+200)
  • *
  • Posts: 233
    • View Profile
Re: Weird sprite glitch.
« Reply #7 on: April 22, 2019, 06:41:29 pm »
Cool thanks.

IHBP

  • Architect of Kajar
  • Enlightened One (+200)
  • *
  • Posts: 233
    • View Profile
Re: Weird sprite glitch.
« Reply #8 on: April 24, 2019, 05:47:00 pm »
Ok so assuming I'll always have a party of three when this is activated and only want to control I NPC I should have 7E0197-99-9B all set to double the number of the object ( in my case object 13 so 26)?

Here's what my setup looks like now.

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Re: Weird sprite glitch.
« Reply #9 on: April 24, 2019, 07:33:45 pm »
- Only change the 7E019x values for PCs you're replacing. If you're changing a party of 3 to a party of 1, either remove the other two PCs, or add commands to deactivate the rest of the party and set unused slots to 80.
- The GetObjectCoords/Facing is only necessary if you want to traverse between locations. It will properly reinitialize the NPC to sprite locations.
- 7E1112 is for working with object 9. Use 7E1126 for object 13.
- Pay close attention to where I placed the return command in that sample. Too much ahead of it causes the weird sprite glitch mentioned in this topic.

IHBP

  • Architect of Kajar
  • Enlightened One (+200)
  • *
  • Posts: 233
    • View Profile
Re: Weird sprite glitch.
« Reply #10 on: April 24, 2019, 08:08:21 pm »
Yup that did it. Just gotta put on the finishing touches now.

And thanks again.

Redline57

  • Guardian (+100)
  • *
  • Posts: 120
  • Crimson Echoes rocks, cease and desist THIS square
    • View Profile
Re: Weird sprite glitch.
« Reply #11 on: June 11, 2019, 02:22:28 am »
Thats the finger from Double Dragon i think?

Mauron

  • Guru of Reason
  • Magical Dreamer (+1250)
  • *
  • Posts: 1461
  • Nu-chan
    • View Profile
    • Maurtopia
Re: Weird sprite glitch.
« Reply #12 on: June 11, 2019, 02:38:23 pm »
That's the finger from Chrono Trigger in yellow.

Zakyrus

  • Architect of Kajar
  • Dimension Crosser (+1000)
  • *
  • Posts: 1216
    • View Profile
Re: Weird sprite glitch.
« Reply #13 on: June 14, 2019, 04:19:27 pm »
I've seen instances where the return is in the middle, I never understood the point of it.

I've come across this before...
From what I can tell, it seems to halt certain Commands (the End much like Return, closes the statement, both are simular). From a 'micro-controller stance'(I've been doing alot of Arduino/RasPi stuff in recent years), its like read a PIN(in this case Command or load the Objects), then GOTO the next PIN(in this case Return in the Object0's Startup/Idle), then from there read the next PIN(continue reading in the next commands), this might have something to do with the Original Cartridge(e.g. Microcontroller PINs) having to read/write in a simular way and has some 'oddball' constraints.

This might also have something to do with those types of Sprites that use a goto_loop (such as repeat animating sprites) and those need to be read in as such.

~Z
« Last Edit: June 14, 2019, 04:48:49 pm by Zakyrus »